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Overview
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What is Help?

• Online ‘self-help’ tool that provides 
users step-by-step instruction and 
policies for using Advance 

—Advance Standard Help 

• Displays standard ‘generic’ 
procedures for navigating and using 
the application

—Site Help

• Custom help file that includes policies 
and procedures specific to the 
institution and their use of Advance
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Help Author Goals

• Define the audience and what information 
would be helpful for them to know

• Develop the site help file in a way that 
allows users to easily navigate and find 
information

• Include fully-tested and institution specific 
procedures/policies for using Advance

• Maintain consistency in look and feel of the 
help project

• Keep the help file current and 
communicate updates to users regularly
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Advance Standard Help
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Sample Site Help File
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What is Adobe RoboHelp Office?

• The TOOL we use!

• RoboHELP is the industry standard in help 
authoring

• RoboHelp is the fastest, most user-friendly 
way to develop professional Help systems and 
documentation for desktop and web-based 
applications
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RoboHelp Office

• Includes RoboHelp for Word and RoboHelp 
HTML applications

—RoboHelp for Word is used to create help files 
for Advance Windows; RoboHelp HTML is used 
for Advance Web Interface

• Can generate WebHelp, HTML Help, 
FlashHelp, WinHelp, JavaHelp, Oracle Help, 
and pure HTML outputs and printed 
documentation all from one source project 

— We support:

• WebHelp for Advance Web

• WinHelp for Advance Windows
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What is WebHelp?

• The VEHICLE we use to create Help for the 
Advance Web Interface!

• HTML-based format designed to run on 
various browsers/platforms

• Generates .HTML, .XML and graphic files that 
can be deployed to individual users or placed 
on a server
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System Requirements

• Microsoft® Windows Vista® with Service Pack 
2, Windows® XP with Service Pack 3, or 
Windows 7

• Microsoft Word 2010, 2007 or 2003 (for printed 
documentation)
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Task 

• Open Adobe RoboHelp9 HTML

• Open sample WebHelp Project using File > Open or 
‘Open’ link under Recent Projects heading

• Navigate to where RoboHelp 9 Was installed and 
access the sample ‘Salesbuilder-Help.xpg’ file
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Questions? Comments…

? ??
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Developing Your Help File

1. Design and create project

2. Develop table of contents/add topics

3. Add topic content and format

4. Build hyperlinks

5. Add graphics

6. Develop Index

7. Generate help file
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Design and 

Create  

Project
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What is a Project?

• All of the files that are used to generate the site 
help file

• Includes all of the policy/procedure text (content), 
graphics, other formatting properties and what the 
output will look like

• Assists in organizing/managing the help file

• The project file will have an extension of .xpj

• This is the file you will access when trying to re-
open your project after it has been created
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Designing a Project

• There are many approaches to designing a 
project

• Some important areas to think about before 
building your help file include:

—Develop an outline of topics 

—Identify naming convention for topics, files, 
projects

—Determine style sheet/look of help file

• Quick start your project by purchasing the site 
help starter kit

—Pre-defined topics, naming conventions, links
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Multiple Help Projects

• No difference in the finished help system if you use 
one or multiple projects

• Necessary when you have multiple help authors 
needing to work at the same time

• Helpful when your help system includes different 
types of information that may/may not all be 
deployed to same users

• Assists in organization
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Planning

• Understand your audience, application and subject 
matter and put this in your design specification 
document

• Create user task lists

• Determine the type and number of help topics 
you’ll need

• Coordinate your efforts with other authors, subject 
matter experts, and application developers
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Designing Your Help System

• Create an outline of the Contents tab

• List any topics you won’t include in the 
Contents tab

• Create a storyboard/flowchart showing how 
users will navigate through the help system
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What are Help Topics?

• Help topics are the basic building blocks

—Generally they cover a single idea

• Help topics are like papers in a folder or pages 
in a book

• There are many types of help topics
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Information Types / Topic Types

• Overview (“What?)

• Task or Procedure 
(“How?”)

• Definition or Glossary

• Policy (“Why? When?”)

• Example (“Give me an 
example”)

• Navigation (“Where?”)

• HTML/Link to Topics

A good help system is a collection of answers to 
anticipated user questions:
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Topic Titles

• Verb first and concept second

• Action verbs best (e.g., Reversing a Gift)

• Avoid jargon

• Avoid single-word titles

• End user oriented
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Procedure Topics

• Written to answer the question “How do I…?”

• Contain step-by-step instructions

• May have links to reference, definition, show me, 
or example topics

• User learns how to take action
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Guidelines for Procedure Topics

• Number your steps

• One action per step

• Simple language

• One method for doing 
the action

• Precise in naming 
buttons and fields as 
they appear

• Enough information for 
a beginner or 
experienced user

• Values or variables 
needed to complete the 
step are available
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Definition Topics

• Written to answer the question “What does this 
word/term mean?”

• Typically display in popup windows or a glossary 
and are therefore short

• User gets the accurate definition
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Guidelines for Definition Topics

• Repeat the word being defined

• Present tense

• If the term is an object, describe how it looks or 
acts, or what it does

• Provide an example if it helps define the term

• Avoid nesting other popup definitions in the 
definition topic
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Navigation Topics

• Show the user how to get from one place to 
another in the application

• May include step-by-step instructions

• May have links to example topics

• May appear in popup windows

• Give your user a way to get back to your 
navigation topics easily
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HTML/Link to Topics

• You may link to or make Internet/Intranet pages 
their own topics

• Provides the look and feel of the Web within your 
help system

• Opens a world of information to your users
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Planning Tools

• Create a Design Document:  define audience, 
requirements, platforms, organization, 
navigation, content

• Build a Prototype:  show a small subset of 
planned topics, show structure, appearance, 
and navigational devices

• Build a Schedule:  Show dates and 
dependencies, and priorities
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Prototype & Schedule

• The prototype communicates your vision for the 
help system

• Demonstrates everything that you will do but on a 
smaller scale

• Get feedback & approval on the prototype

• Build your project schedule and budget:

—Rough estimate is that each topic takes 
between 2-5 hours
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Implementation Tools

• Let’s look at some tools to help you get started 
and track your work…

—Building a topic list

—Establishing Format and Design

—A Help Author’s checklist

—Tracking development
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Task 

You are assigned to design and produce a prototype 
of Site Help for your institution. Consider using the 

topic list document to brainstorm topics and 
tracking spreadsheet to help begin outlining your 

help project.

Note: While eventually we need online help for all of 
your institution’s policies and procedures, let’s start 

with a small subset!
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Task (Continued)

Begin to design your Site Help system

—Take a look at what you want to document 
online

—Consider what topics you’ll need, if there is 
existing content, how you will format this 
information in site help, etc. 

—What topic titles will you use? 

—How do you want to structure the Table of 
Contents tab?

Sketch out your design
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Questions? Comments…

? ??
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Getting Started

• Click the RoboHelp Starter shortcut on your desktop

OR   

• Navigate to the RoboHelp program files directory 
from the Windows Start menu and select RoboHelp 
HTML
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RoboHelp Starter

• Create a new blank project or open an existing 
project
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Project Wizard

Title users will see in 

browser/viewer

Default 

language

Where project 

files are stored
First topic in 

project 

Project file name

WebSearch 

functionality

*If replacing standard Help, Project Name must be:   
Advance_Web_Access_Online_Help *   OR if you purchased 
the site help content kit
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Program Window
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Pods

• A pod is a quadrant or pane of the program window 
that can be moved/organized as the user desires.  
Available pods:

•Project Manager
•Conditional Build Tags
•User-defined Variables
•Single Source Layouts
•Project Set-up
•Snippet
•Output View

•Toolbox
•Bug Hunter
•RoboHelp Server
•Link View
•Topic List
•File Status
•Starter 
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Environments

The Environment defines the pods, toolbars and 
options that display in your program window.  You can 
use several methods to alter this look:

1.   Click different options in one of the pods 

• For example, open the Table of Contents folder in the Project 
Manager pod and double click one of the TOC’s that is listed.  
Your TOC will now appear in a new pod to the right; 

2. Save new environment

• Click the Workspace Switcher button in upper right > Save 

3.    Reset to the default environment

• Click the Workspace Switcher button in upper right > Default

4.   Load an environment that you have previously defined

• Click the Workspace Switcher button in upper right > Load
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Table of Contents -

Topics
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Table of Contents Entries

• TOC entries appear in the TOC tab of the Help 
Topics window as books & pages

• You can create the TOC as you work or at the end 
of the project

• You do not have to include every topic in the TOC

• You must keep the TOC entries in synch with the 
actual topics in your help project
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Table of Contents

• Helpful organizational 
tool when used prior to 
adding the content
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Table of Contents Buttons

6. Move up

7. Move down

8. Create/View TOC

9. Insert placeholder

10.New merged project

11.Discard changes

1 52 3 4 7 8 9 106

1. Create new book

2. Create new page

3. Auto Create TOC

4. Move left

5. Move right
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Creating Books in the TOC

1. Click the New TOC 

Book button

2. Enter a title for the 

book

3. Click OK
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Creating Pages in the TOC

1. Click the New TOC 

Page button

2. Enter the topic title

3. Click the New Topic 

button
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Creating Pages (cont.)

4. Topic Title will default

5. File Name will default.  

Change as necessary 

or desired 

6. Click the various other 

tabs to add attributes 

to the topic if desired

7. Click OK (twice)
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Reordering TOC Entries

• Drag and drop

OR

• Select a book or topic, 
and then use the arrow 
buttons to move it where 
you want
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Task 

Add Books and Pages to Project
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Saving and Viewing Your Work

• Throughout developing your help file, you will 
want to save and compile your work

1.To Save, click 

2.To Generate (compile the project), click

3.To View, click the ‘View Results’ button in the 
popup box that appears
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Task 

Save and Generate Project

View Help File
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Topics Properties

• Topic properties are characteristics such as the 
title,  index entries and topic status

• You can view and change topic properties in the 
“Topic Properties” dialog box by right clicking on a 
topic

—Often used to assist in managing a project

—Will display in Reports for tracking purposes
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Topic Properties
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Changing Properties for a Group of Topics

1 In the Topic List, select all the topics whose 
properties you want to change (use Shift-click 
and Ctrl-click, as necessary)

2 Right-click one of the selected topics, and then 
from the shortcut menu choose Status, Author, 
Priority, or another property you want to change
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Task 

View Topic Properties

Change a Group of Topic Properties
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Questions? Comments…

? ??
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Topic 

Content and 

Format
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Topic Content

• There are several methods for getting content into 
the help file

—Type text directly in to the topics

—Copy and paste text from other documents

—Import document using RoboHelp
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Creating Topics by Importing Existing Documents

• You can import existing .DOC files into your help 
project

—Can also import .PDF, .HTML plus more

• It’s a good idea to import external files into a new, 
empty help document

• RoboHELP can automatically convert imported 
text into help topics
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Importing Word Docs

1. Create a New Topic 
folder for your 
imported docs 
(Project Manager pod 
> right click Project 
files folder to create 
new) then highlight 
the folder

2. From File menu, 
select Import > Word 
Document

3. Navigate to where 
the file is stored

4. Double-click the 
selected WORD file 
OR click ‘Open’
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Importing Word Docs (cont.)

4. DO NOT select 
any options in the 
Content Settings 
popup box.  

5. Click ‘Next’

6. Click the ‘Edit’ 
button in the 
section titled 
‘Word Document’ 
to apply a style or 
apply later
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Importing Word Docs (cont.)

6. Click the plus (+) 
sign next to the 
Paragraph listing

7. Click Heading 1

8. Click the 
Pagination 
checkbox

9. Click OK

10.Click Finish

11.Import completed
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Word Import Results
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Add New Topic to TOC

1. Click the Topics List pod

2. Highlight the topic to add to the TOC and drag and 
drop it in the proper location in the TOC
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Task 

Import Word Documents

Add Topics to TOC

Save and Generate Project
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Importing Topic Content Manually

• You can also import content by utilizing the 
copy/paste functionality

• Create your topic then copy the content from the 
external document and paste into the desired topic

• Formatting will often be lost when text is copied
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Task 

Manually Enter Content into an Existing 
Topic

Save and Generate Project
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Importance of Styles

• RoboHELP uses styles to determine how to 
convert imported text to help topics

• Check for consistent use of style in the document 
you are importing; if styles are inconsistent or 
incorrect, adjust them before converting the 
imported text
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Cascading Style Sheet (.CSS)

• A style is a formatting element that controls font 
size/color, line spacing, alignment and other 
attributes alignment

• Style sheets are a collection of styles that can be 
attached to HTML files to control the layout and 
appearance of multiple HTML topics without 
editing the topics individually

—Example, change Heading of each topic to Arial 
12 Bold
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Creating a Style Sheet

1. Open any topic

2. Click Style Sheet 
button on toolbar

3. Click New

4. Enter name of new 
style and folder 
location

5. Click Copy Styles from 
checkbox if you want to 
build your new style 
from an existing one.  
Select base style from 
dropdown

6. Click Create
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Creating a Style Sheet (continued)

7. Under ‘Styles’, click plus sign (+) to expand the 
section that contains the element you want to 
reformat

8. Click the element (e.g. Heading 1) to view the 
current settings and a preview of the element as 
it will display with these settings

9. Change format (font size, color, style, 
indentation, etc.) as desired

10. Click Apply

11. Repeat #8-10 as needed

12. Click OK
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Creating a Style Sheet (continued)



RoboHelp for Web 3/9/2012

Datatel+SGHE - Confidential and Proprietary 37

Datatel+SGHE | www.sungardhe.com 73

Viewing Topic Style

To determine what 
style is applied to a 
topic:

1. Highlight the topic 
in the Topic List

2. Right click and 
select properties

3. Click on the 
Appearance tab

* To change style, click 
desired .css file and 
click Apply then OK
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Apply Style to All Topics

1. Click the Topics Tab

2. Highlight the topics in 
the list

3. Click the Properties 
button

OR

Right-click while 
hovering over the 
highlighted area and 
click Properties

4. Click the Appearance 
tab

5. Highlight the desired 
style sheet

6. Click Apply

7. Click OK
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Task 

Modify a Style Sheet

Apply Style to All Topics

Save and Generate Project
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Skins

• Skins allow you to integrate your output visually 
with your institutions ‘look’

• Change colors, buttons, fonts, backgrounds for 
TOC icons and navigation buttons in your final 
help product
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To Create a Skin

1. Access the Project 
Set-Up pod by clicking 
the tab OR by clicking 
View > Pods > Project 
Set-Up 

2. Right click on the 
Skins folder and select 
New Skin

3. Click radio button for 
‘Create custom 
WebHelp skin

4. Click OK 
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To Create a Skin (cont.)

5. Click the Toolbar or Navigation 
tab to view the items whose 
display you can edit

6. Click the item you wish to edit

7. Modify information as desired 
(change font, add image, etc.)

8. Click OK

9. Enter a name for your new 
skin

10. Click OK to save your new 
skin
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New Skin!
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Change Primary Layout

1. View the Single 
Source Layouts 
Pod

2. Highlight WebHelp
(Primary Layout)

3. Right click and 
select Properties

4. Choose desired 
Skin from Skin 
dropdown list

5. Save

(In RoboHelp Version 9, 
your new skin may appear 
under WebHelpPro
instead of Primary Layout, 
and you may need to click 
“Save and Generate rather 
than just “Save.”)
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New Look!
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Task 

Create a New Skin

Save and Generate Project
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Questions? Comments…

? ??
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Hyperlinks
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Hyperlinks

• Hyperlinks (links) allow users to navigate through 
the help system to quickly find information
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Types of Links

• Common types of links include:

—Text Links – Text that when clicked jumps the 
user to a new destination (hotspot)

—Popups – A link that displays an HTML topic in 
a window that pops up

—Expanding and Dropdown Hotspots – links that 
display additional text in the topic content when 
clicked

—Link Controls - List of additional similar topics
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Text Link

• Text links typically display in a blue font with an 
underline (color can be changed)

• Clickable text that when a user moves the mouse 
over the text, the pointer turns into a hand
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Text Link

1. Place the cursor 
where you want 
the link (or 
highlight the text 
for the hotspot)

2. Click Insert 
Hyperlink

or

Insert > 
Hyperlink/Popup

3. Select the 
Destination for 
the link

4. Click OK
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Link to Web Addresses

1. Place the cursor 
where you want the 
link (or highlight the 
text for the hotspot)

2. Click Insert 
Hyperlink

3. Select Web Address 
from the Link to 
dropdown

4. Enter the web 
address

5. Indicate display in 
frame (New window)

6. Click OK 
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Link to Email

Screen tips will display 

when a user pauses 

over hotspot

1. Place the cursor 
where you want the 
link (or highlight the 
text for the hotspot)

2. Click Insert 
Hyperlink

3. Select Email from 
the Link to 
dropdown

4. Enter the email 
address

5. Click OK
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Task 

Link Text, Web Address, Email

Save and Generate Project
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Popups

1. Place the cursor 
where you want the 
link (or highlight the 
text for the hotspot)

2. Click Insert Popup

3. Click the New topic 
button

4. Enter a topic title
5. Adjust filename as 

necessary (prepend 
with ‘popup_’, etc.)

6. Click OK twice

Maybe add a 

prefix to file name 

for reference
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Popups (cont.)

6. In the Topic List 
pod, navigate to the 
popup topic you 
just created

7. Double-click the 
topic to open it

8. Add/edit text that 
you want to display 
for the popup

9. May consider 
changing the 
style/font size for 
popup topics to 
smaller text
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Quick Text Only Popups

1. Place the cursor 
where you want 
the link (or 
highlight the text 
for the hotspot)

2. From the Insert 
menu, select Text 
Only Popup

3. Enter the text
4. Click OK 
5. To Edit text after 

creation, double-
click on hotspot or 
right click and 
select Text Popup 
Properties
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Task 

Create Popups and Text Only Popups

Save and Generate Project
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Expanding/Dropdown Hotspots

• Expanding: Users clicks text and it expands to 
display additional information after the linked 
word(s); click again and text disappears

—Oftentimes used for definitions

• Dropdown: User clicks text and additional 
information displays below the hotspot

—Frequently used for graphics

—More detailed steps for a procedure
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Expanding Hotspot

1. Place the cursor 
where you want 
the link (or 
highlight the text 
for the hotspot)

2. From the DHTML 
menu, select 
Create Expanding 
Hotspot and Text

3. Enter text and 
when complete 
click outside of 
the text editor box

4. Click Preview to 
view hotspot

Note: Hotspot formatting can be 

changed by modifying the style
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Dropdown Hotspots

1. Place the cursor 
where you want the 
link (or highlight the 
text for the hotspot)

2. From the DHTML 
menu, select Create 
Dropdown Hotspot 
and Text

3. Enter text and when 
complete click 
outside of the text 
editor box

4. Click Preview to view 
hotspot
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Task 

Create Expanding and Dropdown Hotspots

Save and Generate Project
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Link Controls

• Link controls provide another navigation option in 
the form of text, buttons or images that display a 
list of related topics

—Related Topics

—See Also

—Keyword Links
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Related Topics

1. Click Insert Nav 
Control button

2. Select Related 
Topics and the 
Wizard will open

3. Select radio button 
options and click 
Next

4. Highlight the Topics 
in Project and click 
Add to include them 
in the Related Topic;  
click Next when done
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Related Topics (cont.)

5. Indicate Display 
Options for when the 
users click the 
control 

6. Click Next to set up 
font options 

7. Click Finish

8. If you need to change 
your Related Topics 
options, double-click 
the button/listing 
within your help 
document
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Task 

Create a Related Topic Link

Save and Generate Project
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See Also Topic Properties

• Right click ‘See Also’ 
link in Project 
Manager pod

• Click ‘Edit’

• Type See Also 
keyword in box and 
click ‘+’ sign or Enter

• Highlight See Also 
keyword and then 
drag topics from 
Topic List pod to 
‘Topics for:’ box

You can also link ‘See Also’ keywords to topic 

through ‘See Also’ tab in Topic Properties
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See Also Links

1. Click Insert Nav 
Control icon

2. Select See Also
3. Wizard will open
4. Select radio 

button options 
and click Next

5. Highlight the See 
Also Keywords in 
Project and click 
Add to include 
them in the See 
Also Control

6. Click Next when 
done
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See Also Links (cont.)

5. Indicate Display 
Options for when 
the users click the 
control 

6. Click Next to set up 
font options 

7. Click Finish
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Task 

Create a See Also Link

Save and Generate Project

Datatel+SGHE | www.sungardhe.com 108

Questions? Comments…

? ??
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Bookmarks
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Bookmarks

1. Position your cursor 
where you want 
bookmark

2. Click Insert 
Bookmark button
or

Insert > Bookmarks 
3. Enter a name for the 

bookmark
4. Click OK
5. RoboHelp will insert 

a bookmark icon
* Create a hyperlink to 

this bookmark from 
any topic using 
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Task 

Add a Bookmark

Create a Link to a Bookmark
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Find & Replace
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Find and Replace in Multiple Files

1. Click Edit > Find and Replace in Files
2. Enter the text/symbols to find in your documents
3. Enter the text/symbols to insert in place of your 

‘Find’ options
3. Use Browse to identify the location of your 

RoboHelp project
4. Place checks in checkboxes as needed.  Case 

Sensitive is one that you might want to use
5. Click Find
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Find and Replace in Multiple Files (continued)

6. RoboHelp will find all files in your chosen 
folder/location that contain the ‘Find’ data you 
specified. 

7. Select files and click action buttons (Replace, 
Replace All, etc.) as needed

IMPORTANT NOTES:

• Refer to RoboHelp Help              for additional 
information and definition of various options

• RoboHelp saves your changes upon completion of 
the action.  So…you might want to save a backup of 
your project before doing a Find and Replace



RoboHelp for Web 3/9/2012

Datatel+SGHE - Confidential and Proprietary 58

Datatel+SGHE | www.sungardhe.com 115

Find and Replace in Multiple Files (continued)
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Find and Replace in a Single File

1. Open the Topic you wish to edit
2. Click Edit > Replace

* NOT Edit > Find and Replace in Files *
3. In the ‘Find what:’ box, enter the text/symbols to find 

in your documents
4. In the ‘Replace with:’ box, enter the text/symbols to 

insert in place of your ‘Find’ options
3. Place checks in checkboxes as needed.  Match Case 

one that you might want to use
5. Click the button for the action you want to take
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Questions? Comments…

? ??
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Images
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Types of Images

• Recommended file type for graphics is  .GIF or 
.JPG image files 

—.BMP files do not display properly in some 
browsers
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Capturing Graphics

• ALT+Print Screen captures the active screen; 
CTRL+V will paste it into a topic

OR

• Use a screen capture program (i.e. Hypersnap) to 
obtain image files
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Inserting a Graphic

1. Position cursor 
where you want 
the graphic to 
display

2. Click the Insert 
Image button

3. Click Browse 
button to locate 
image file

4. Indicate image 
attributes

5. Click OK 

* We recommend sizing 
before inserting
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Horizontal Lines

1. Insert > HTML > 
Horizontal Line

2. Position cursor on 
line that RH creates

3. Double-click to 
display line 
attributes

4. Modify line 
attributes

5. Click OK
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Clickable Graphic (Shed)

1. Open the topic 
containing the image 

2. Click Insert > Image 
Map

3. From the submenu, 
select a shape that will 
outline the click area

4. Drag shape to place
5. In ‘Select Destination 

(file or URL), select 
Topic to which you 
want to link.  If you 
need to create a new 
Topic, click New Topic 
button and create

6. Click OK
7. Open Topic (if you 

created new) and add 
text – MME Update
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Clickable Graphic (cont.)
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Other Image Options

• Select a graphic from the gallery

• Create a dropdown link graphic

• Create a popup link graphic

• Add a background image to a topic

• Use images as links (jumps) to other topics

• Multimedia

• Insert tables and text boxes
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Task 

Add a Graphic to a Topic

Create a Dropdown Graphic Link

Add a Horizontal Line

Save and Generate Project
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Questions? Comments…

? ??
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Index
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Indexing

• An index is a list of words that a user thinks of 
when he/she has a question about an application

• Allows users to find words associated with their 
question and to display relevant topics

• An index gives users quick access to information 
in your help file

• Using an index is faster than searching through 
the table of contents to find something

• An index is created by associating a keyword with 
a topic

• Smart Index Wizard will auto create index words
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Creating an Index Manually

1. Click on Index tab 
with Topic tab 
displaying in the 
right pane

2. Drag and drop 
topics into the Index 
box on the left

3. And/or Type a word 
in the open box at 
the top and click 
Add then drap the 
appropriate topic to 
the left to link
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Task 

Manually Create an Index Item

Save and Generate Project

View Index
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Questions? Comments…

? ??
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Generate 

Site Help 

File
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Generating Primary Output

• WebHelp is an uncompiled output that 
supports standard Help features (TOC, index, 
and search) and customized appearance

• Generate the project when ready to view

—RoboHelp creates output files in a single folder 
(called "WebHelp") within your project folder 
that you distribute to end users or publish to 
another location



RoboHelp for Web 3/9/2012

Datatel+SGHE - Confidential and Proprietary 68

Datatel+SGHE | www.sungardhe.com 135

Generating Primary Output

• Throughout developing your help file, you will 
want to save and compile your work

1.To Save, click 

2.To Generate (compile the project), click

3.To View, click ‘View Results’  

Review ☺
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Project Reports

• Project reports provide various details about a 
project including a list of table of content entries, 
keywords, missing links, unused files, status of 
topics etc.

• Reports can be printed, emailed or exported as .txt
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Viewing Reports

• To view various reports, 
select from the Tools 
menu > Reports
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Project Status Report
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Table of Contents Report
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Task 

View Several Project Reports
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Conditional Build 

Tags
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Creating Conditional Build Tags

• Access the Conditional Build pod:
1. Click the Conditional Build tab at the bottom of the Single 

Source Layouts pod or;

2. Click View -> Pods -> Conditional Build Tags

• Right click anywhere in the pod and choose ‘New 
Conditional Build Tag’

• Enter a name for tag
• Click the icon to the right of the new name to choose 

the tag color
• Click OK to save your tag
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Applying Conditional Build Tags from Table of Contents

1. Right click on the TOC item for which you want to apply a 
conditional build tag

2. Click ‘Apply_Conditional_Build_Tag’

3. To apply to both TOC item and Topic (topic won’t be included 
in published TOC or Help files):

i. Choose New/Multiple

ii. Click the TOC and Topics checkbox beside the Build 
tag(s) you want to apply

iii. Click OK

4. To apply to the TOC item only:

i. Click the row of the Build tag you want to apply

Datatel+SGHE | www.sungardhe.com 144

Applying Conditional Build Tags from Topic Pod

1. Right click on the row of the Topic for which you want to apply 
a conditional build tag

2. Click ‘Properties’

3. Click the ‘Advanced’ tab

4. In the Topic-Level Tags box, click the checkbox beside the 
Build tag(s) you want to apply

5. Click OK

Topic Build Tag column

should now display the

name of the build tag you

applied
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Printing Your 

Help File
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Creating Printed Documentation Layouts

1. Access the Single Source Layouts pod:
i. Click the Single Source Layouts tab at the bottom of the 

Conditional Build pod or;

ii. Click View -> Pods -> Single Source Layouts

2. Right click anywhere in the pod and choose ‘New 
Layout’

3. Enter a name to identify the printed documentation 
layout (e.g. Barringer University Advance Web Help, 
TEST Print, etc.)

4. Choose ‘Printed Documentation’ from the Output Type 
dropdown list.

5. Click OK to save your layout
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Formatting Printed Documentation Layouts

1. If Print Document General box is not open, right click 
on the name of the printed doc layout you want to edit 
and click ‘Properties’

2. Click the checkbox(es) of the output formats you want 
to generate (WORD, .pdf, both?)

3. Enter a name to identify the printed documentation 
layout (e.g. Barringer University Advance Web Help, 
TEST Print, etc.)

4. Change ‘Name’ in Printed Documentation box, if 
necessary.  This is the name that will print on the cover 
page of the generated document

5. Change output folder/location as necessary
6. If you want to exclude topics/TOC items to which a 

conditional build tag has been applied, click the 
‘Define’ button in the Conditional Build Expression 
section.  Click a tag on the left and use arrows to move 
to right.  Click OK to apply to print layout
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Formatting Printed Documentation Layouts (continued)

7. Choose applicable 
Table of Contents, Index 
and Glossary from 
dropdowns in Content 
section.  In most cases, 
defaults are acceptable.

8. If you do not want to 
include images in your 
main output file, click 
the ‘Link to documents’ 
radio button in the 
Images section.  In most 
cases, you will embed 
images

9. Adjust the settings 
radio buttons as 
necessary.  

10.Click ‘Next’ button
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Formatting Printed Documentation Layouts (continued)

11.Use arrows to 
remove and/or add 
Topics that will be 
printed.  By default, 
all topics not 
excluded by a 
conditional build 
tag will be printed

12.Click ‘Next’ button
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Formatting Printed Documentation Layouts (continued)

13.Use ‘+’, ‘-’ and 
arrows on the right 
side of the page to 
remove and/or add 
sections that will be 
printed.  By default, 
all sections will be 
included

14.Click ‘Next’ button
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Formatting Printed Documentation Layouts (continued)

15.If you want to 
globally apply a 
stylesheet to your 
printed topics (this 
is unusual as you 
would normally 
apply styles within 
project), choose a 
style from the 
‘Apply CSS to all 
Topics’ dropdown

14.Click ‘Save’ button
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Generating Printed Documentation

1. Access the Single Source Layouts pod:
2. Right click on the printed documentation layout you 

want to generate
3. Click ‘Generate’
4. If you need to make changes to your print options, 

change items as necessary and use the ‘Next’ button to 
move from page to page

5. Click the ‘Finish’ button when you are ready to produce 
your printed documentation

6. RoboHelp will begin generating your printed 
documentation in your selected output format

7. When RoboHelp has completed your document 
generation, you will see a popup box.  Click ‘View 
Result’ to see your document.
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Final Build/

Publishing
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Formatting the Final Build/Publishing 

1. Access the Single Source Layouts pod:
i. Click the Single Source Layouts tab at the bottom of the 

Conditional Build pod or;

ii. Click View -> Pods -> Single Source Layouts

2. Right click on the ‘Web Help (Primary Layout)’ item

3. Click ‘Properties’

4. In the ‘Select Output Folder and Start Page’ box, 
indicate where you want to publish your project.  
i. Publish the file locally.  Publishing to the server can be very 

slow.

ii. Remember that your output file needs to be named 
Advance_Web_Access_Online_Help.htm if you are replacing 
standard Advance Web Online Help.
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Formatting the Final Build/Publishing (continued)

5. If you want to exclude topics/TOC items to which a 
conditional build tag has been applied, click the 
‘Define’ button in the Conditional Build Expression 
section.  Click a tag on the left and use arrows to move 
to right.  Click OK to apply.

6. The ‘Skin’ section should already be populated with 
your chosen skin.  Change if necessary

7. Choose applicable Table of Contents, Index and 

8. Glossary from dropdowns in Content section.  In most 
cases, defaults are acceptable.

9. Click ‘Next’ button
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Formatting the Final Build/Publishing (continued)
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Formatting the Final Build/Publishing (continued)

10.Edit the Toolbar, Navigation, Search Options and 
Additional Options checkboxes as necessary.
• If you do not want to display the ‘path’  to the Help File topic on 

the topic page, uncheck the ‘Add Breadcrumb Links’ box

• Use ‘Help’ button for more information about these options

11.Click ‘Next’ button

12.Click ‘Next’ button again

13.If you want RoboHelp to prompt you before overwriting 
files during publication, click the ‘Prompt before 
overwriting files’ box.  This option is usually off.

14.Click ‘Next’ button and then the ‘Save’ button
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Generating the Published Files

1. Access the Single Source Layouts pod
2. Right click on WebHelp (Primary Layout)
3. Click ‘Generate’
4. If you need to make changes to your publication 

options, change items as necessary and use the ‘Next’ 
button to move from page to page

5. Click the ‘Finish’ button when you are ready to publish 
your Help file

6. RoboHelp will begin generating your files.
7. When RoboHelp has completed your document 

generation, you will see a popup box.  Click ‘View 
Result’ to see your published Help file.
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Moving the Help File To Advance Web

• Once the project is complete, the necessary files 
will need to be copied to the web server
1.Navigate to the c:\inetpub\wwwroot\ directory 

where AWA is installed, and open the 
"\Help\Advance folder and delete the contents 
(you may make a copy if desired)

2.Navigate to the directory where you published 
the site help file and select/copy the contents of 
the entire directory

3.Paste the contents you copied in step 2 to the 
now empty folder you emptied in step 1

4.Use Advance Web to access the Online Help to 
verify the correct file is in place
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Archiving Project Files

• Archive and backup all project files regularly to a 
separate location on your server/removable 
storage device

• Archive current copies of .CSS and Skins

• Copy zipped files to network folder

• Keep record (perhaps in excel) of modifications 
made

• Keep daily copies on your c: drive

• Keep 3 – 4 backups in chosen locations
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Questions? Comments…

? ??


